Home Forums TrueRNG Hardware random number generator Trouble with installation

This topic contains 5 replies, has 2 voices, and was last updated by  johnnytheswede 5 years, 7 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #2067

    Hi, i have just got a new TrueRNG3 in the mail.

    I have attempted to install the device on three systems, i got it working on a Windows system (and extracted and checked the random sequence produces) so the device itself is working.

    The trouble with two different linux systems seems to be that linux can’t find the device. I’m in Debian 6 and Debian 8. Both systems respond well to apt-get install rng-tools and the standard rule-file (called 99-…) is in place in /etc/udev/rules.d.

    However, i try to restart the deamon and get the message

    Starting Hardware RNG entropy gatherer daemon: (Hardware RNG device inode not found)
    /etc/init.d/rng-tools: Cannot find a hardware RNG device to use.

    I read somewhere in a review that installation proceeded fine once the correct kernel module was found and installed … this feels like a kernel module issue to me, any hints on what that module could be or any other hints or leads would be very nice.

    Kindest regards


    Ubld.it Staff

    Hi there Johnny.

    So by default the udev rules create the /dev/TrueRNG node (which is a symlink to /dev/ttyACM0 or 1, depending…)

    Can you verify some nodes for me ?

    ls -l /dev/ttyACM*
    ls -l /dev/TrueRNG*

    if both /dev/ttyACM0 and /dev/TrueRNG exist, then the problem is in the rng-tools conf file. it defaults to using /dev/hwrng and not /dev/TrueRNG. Simply edit the config file and replace /dev/hwrng with /dev/TrueRNG and restart, and it should be working.

    This is step #2 in the install guide for reference.

    Hopefully that fixes the issue.


    Thank you very much for your prompt reply. I have solved the problem, but i opted for a slightly different version, i know i have seen the config file *somewhere* but it was not at /etc/conf.d/, anyhow i added another symlink in /dev:

    lrwxrwxrwx 1 root root 7 Apr  4 19:10 /dev/hwrng -> TrueRNG

    which solved the problem, i can now read from /dev/TrueRNG with dd. (I have not checked what i receive but if there are more problems, i’ll get back.)

    However, if anyone knows where the config file for rng-tools in Debian, i’d be happy to know so that in future tweaks, i’l be at the right place.

    Kindest regards


    Ubld.it Staff

    Thats one way to tackle it, we opted not to symlink to /dev/hwrng because if you had an internal hwrng like with your cpu (which some have, can’t say how good they are they use thermal noise usually) they would use /dev/hwrng so to avoid conflict we used a different name. I would think that Debian would have the config file in the same place as Ubuntu which is /etc/default/rng-tools


    Thank you for your responses, i found the config file and selected /dev/TrueRNG as the device and it seems to be working fine now in this way, however, there seems to be one more move necessary for it to work, to get permission to read from /dev/TrueRNG i have to do, as root

    chmod a+r /dev/ttyACM0

    i kind of feel fine with this, but are there any comments around this? In the future i plan to suid a certain process that does an

    execlp("/bin/sh","/bin/sh","-c","chmod a+r /dev/ttyACM0",NULL);

    in a child process, but that feels a bit heavy-weight, is there any way to get the reading permissions on /dev/ttyACM0 to be persistently granted?

    Kindest regards


    Hi again, i just realized that the correct way was to add my user to the dialout group, not it all works smoothly! Thank you for all your input, it think this thread now contains a lot of valuable info, i hope others can use it too.

    Kindest regards

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.