Home Forums TrueRNG Hardware random number generator [Ubuntu 15.04] TrueRNGpro doesn't show off in /dev/TrueRNG

This topic contains 2 replies, has 2 voices, and was last updated by  Ubld.it Staff 3 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #1555



    I recently received my RNGpro and wanted to install it under Ubuntu 15.04, but after following the instructions (wget, unzip rules.d, plug in RNG) I get a “no such file or directory” if I type “ls -l /dev/TrueRNG” (LED PWR, G1, G2 are ON, ACT is OFF).
    Afterwards I’ve tried to search for the device in the /dev/ directory and found under /dev/serial/by-id/ a file named “usb-Ubld_Electronics_LLC_TrueRNGpro_00002024-if00″ that points to the address /dev/ttyACM0. Can I use this address to get my entropy for my applications or what shall I do/have I done wrong at the installation?

    Thank you for your support.
    Daniel Werner


    Ubld.it Staff

    Sorry for the late response, somehow this post snuck past us. Yes you can use /dev/ttyACM0, however, the udev.d script does more than just symlink to /dev/TrueRNG it makes sure the term settings are in raw mode. I’ve tested the TrueRNG (and TrueRNGPRo) under 15.04 and it works just fine. The only reason I could see that you don’t have /dev/TrueRNG is the scripts were unzipped to a subfolder. There is appears to be a subfolder in the zip file with the udev script, I’ll look into updating the script so the subdirectory isn’t there but I suspect that is your issue.


    Ubld.it Staff

    I’ve updated the zip file for the pro and it indeed had a subdirectory called Linux, that .rules file needs to be in the udev.d dir not in a subdirectory. So I’ve fixed the zip file. That should fix your problem.

    Sorry about that.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.