This topic contains 4 replies, has 1 voice, and was last updated by  BrianX 8 months, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #2126

    BrianX
    Member

    Im running latest Ubuntu Linux 16 LTS

    I followed the install instructions without issues.

    In checking the logs I get this read error. Permissions issue?

    Jan 5 13:10:51 X02 systemd[1]: Starting rng-tools.service…
    Jan 5 13:10:51 X02 rng-tools[6422]: Starting Hardware RNG entropy gatherer daemon: rngd.
    Jan 5 13:10:51 X02 rngd: read error
    Jan 5 13:10:51 X02 rngd: message repeated 99 times: [ read error]
    Jan 5 13:10:51 X02 rngd: No entropy sources working, exiting rngd

    #2127

    BrianX
    Member

    This may be the same error as an old post. When I check 99-TrueRNG.rules I get. An older post says to change /bin/stty raw -echo -ixoff -F /dev/%k speed 3000000
    to
    /bin/stty raw -echo -ixoff -F /dev/TrueRNG speed 3000000

    IS THIS CORRECT?

    MY 99-TrueRNG.rules

    # ubld.it TrueRNG
    #
    # This rule creates a symlin to newly attached CDC-ACM device
    # Also includes fix for wrong termios settings on some linux kernels
    # New! includes ignore for modemmanger
    # (Thanks neoaeon)
    SUBSYSTEM==”tty”, ATTRS{product}==”TrueRNG”, SYMLINK+=”TrueRNG”, RUN+=”/bin/stty raw -echo -ixoff -F /dev/%k speed 3000000″
    ATTRS{idVendor}==”04d8″, ATTRS{idProduct}==”f5fe”, ENV{ID_MM_DEVICE_IGNORE}=”1″

    An

    #2128

    BrianX
    Member

    After change:

    sudo service rng-tools status
    ● rng-tools.service
    Loaded: loaded (/etc/init.d/rng-tools; bad; vendor preset: enabled)
    Active: active (exited) since Fri 2018-01-05 13:49:15 EST; 7min ago
    Docs: man:systemd-sysv-generator(8)

    Jan 05 13:49:15 X02 systemd[1]: Starting rng-tools.service…
    Jan 05 13:49:15 X02 rng-tools[2481]: Starting Hardware RNG entropy gatherer daem
    Jan 05 13:49:15 X02 rngd[2484]: read error
    Jan 05 13:49:15 X02 systemd[1]: Started rng-tools.service.

    #2129

    BrianX
    Member

    I solved it

    Final Solution:

    cd /etc/default
    sudo nano rng-tools

    Change
    #HRNGDEVICE=/dev/hwrng
    To
    #HRNGDEVICE=/dev/TrueRNG

    # Configuration for the rng-tools initscript
    # $Id: rng-tools.default,v 1.1.2.5 2008-06-10 19:51:37 hmh Exp $

    # This is a POSIX shell fragment

    # Set to the input source for random data, leave undefined
    # for the initscript to attempt auto-detection. Set to /dev/null
    # for the viapadlock and tpm drivers.
    #HRNGDEVICE=/dev/hwrng
    #HRNGDEVICE=/dev/null

    # Additional options to send to rngd. See the rngd(8) manpage for
    # more information. Do not specify -r/–rng-device here, use
    # HRNGDEVICE for that instead.
    #RNGDOPTIONS=”–hrng=intelfwh –fill-watermark=90% –feed-interval=1″
    #RNGDOPTIONS=”–hrng=viakernel –fill-watermark=90% –feed-interval=1″
    #RNGDOPTIONS=”–hrng=viapadlock –fill-watermark=90% –feed-interval=1″
    #RNGDOPTIONS=”–hrng=tpm –fill-watermark=90% –feed-interval=1″

    #2130

    BrianX
    Member

    Very odd because I know saved it during the setup and then it reverted back on reboot. Oh well. Live and learn. its all fixed now.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.